Filed

Degraded AI tax prep performance due to downstream providers under maintenance
Resolved·Degraded performance

The service disruption affecting the Filed app has been resolved, and all systems are operating normally. We apologize for the inconvenience.

Wed, Oct 29, 2025, 10:48 PM
(1 month ago)
·
Affected components
App
Updates

Resolved

The service disruption affecting the Filed app has been resolved, and all systems are operating normally. We apologize for the inconvenience.

Wed, Oct 29, 2025, 10:48 PM

Investigating

We are currently investigating a service disruption impacting AI taxpreps. Our team is actively working to identify the root cause. We will provide our next update as soon as possible.

Wed, Oct 29, 2025, 06:10 PM(4 hours earlier)
Powered by

© 2025 Filed. All rights reserved.